pfSenseをアップデート 2.4.0→2.4.1

pfSenseをアップデートした記録 2.4.0→2.4.1

アップデート内容確認

2.4.0から2.4.1にアップデートします

変更点を確認
2.4.1 New Features and Changes – PFSenseDocs
https://doc.pfsense.org/index.php/2.4.1_New_Features_and_Changes

無線LANのWPA2に関する脆弱性(KRACK)への対策がメインなので
無線LANを使ってる人はなるべく早く適用しましょう

もちろんKRACK以外の部分にも修正が入ってますので
2.4系で有線利用している方も定期メンテ時にでも適用しましょう

2.3系を使っている方へのKRACK対策は2.3.5になります

アップデートの手順

事前に設定のバックアップをした上で以下の操作でアップデートを実行
手順はいつもと同じです

まずダッシュボードのVersionのところにある雲マークか
System→Updateを選択

2.4.0から2.4.1へアップデートと表示出てるのを確認して「Confirm」を押す

無事に完了すると自動で再起動開始されます

最後に2.4.1の状態で設定をバックアップして完了

Update時の処理ログ

>>> Updating repositories metadata... 
Updating pfSense-core repository catalogue...
pfSense-core repository is up to date.
Updating pfSense repository catalogue...
pfSense repository is up to date.
All repositories are up to date.
>>> Downloading upgrade packages... 
Updating pfSense-core repository catalogue...
pfSense-core repository is up to date.
Updating pfSense repository catalogue...
pfSense repository is up to date.
All repositories are up to date.
Checking for upgrades (8 candidates): ........ done
Processing candidates (8 candidates): ........ done
The following 10 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
  wpa_supplicant: 2.6_2 [pfSense]
  hostapd: 2.6_1 [pfSense]

Installed packages to be UPGRADED:
  pfSense-rc: 2.4.0 -> 2.4.1 [pfSense-core]
  pfSense-kernel-pfSense: 2.4.0 -> 2.4.1 [pfSense-core]
  pfSense-default-config: 2.4.0 -> 2.4.1 [pfSense-core]
  pfSense-base: 2.4.0 -> 2.4.1 [pfSense-core]
  pfSense-Status_Monitoring: 1.7.2 -> 1.7.3 [pfSense]
  pfSense: 2.4.0 -> 2.4.1 [pfSense]
  nginx: 1.12.1_1,2 -> 1.12.1_2,2 [pfSense]
  mpd5: 5.8_2 -> 5.8_3 [pfSense]

Number of packages to be installed: 2
Number of packages to be upgraded: 8

The process will require 2 MiB more space.
53 MiB to be downloaded.
[1/10] Fetching pfSense-rc-2.4.1.txz: .. done
[2/10] Fetching pfSense-kernel-pfSense-2.4.1.txz: .......... done
[3/10] Fetching pfSense-default-config-2.4.1.txz: . done
[4/10] Fetching pfSense-base-2.4.1.txz: .......... done
[5/10] Fetching pfSense-Status_Monitoring-1.7.3.txz: ... done
[6/10] Fetching pfSense-2.4.1.txz: . done
[7/10] Fetching nginx-1.12.1_2,2.txz: .......... done
[8/10] Fetching mpd5-5.8_3.txz: .......... done
[9/10] Fetching wpa_supplicant-2.6_2.txz: .......... done
[10/10] Fetching hostapd-2.6_1.txz: .......... done
Checking integrity... done (0 conflicting)
>>> Upgrading pfSense kernel... 
Checking integrity... done (0 conflicting)
The following 2 package(s) will be affected (of 0 checked):

Installed packages to be UPGRADED:
  pfSense-kernel-pfSense: 2.4.0 -> 2.4.1 [pfSense-core]
  pfSense-rc: 2.4.0 -> 2.4.1 [pfSense-core]

Number of packages to be upgraded: 2
[1/2] Upgrading pfSense-rc from 2.4.0 to 2.4.1...
[1/2] Extracting pfSense-rc-2.4.1: .... done
[2/2] Upgrading pfSense-kernel-pfSense from 2.4.0 to 2.4.1...
[2/2] Extracting pfSense-kernel-pfSense-2.4.1: .......... done
===> Keeping a copy of current kernel in /boot/kernel.old
Upgrade is complete.  Rebooting in 10 seconds.
Success