pfSenseをアップデート 2.3.4_1→2.4.0

pfSenseをアップデートした記録 2.3.4_1→2.4.0

アップデート内容確認

2.3.4_1(2.3.4-p1)から2.4.0にアップデートします

変更点を確認
2.4 New Features and Changes – PFSenseDocs
https://doc.pfsense.org/index.php/2.4_New_Features_and_Changes

今回はメジャーアップデートなので変更点が多く注意が必要です

以前から告知されていた以下の項目は予定通り実装されました
32bit版の廃止
NanoBSD版の廃止
ARMサポート開始
FreeBSD 11.0系へ更新
UEFIサポート開始
ZFSサポート開始
OpenVPNの2.4系へ更新

ベースOSの詳細はFreeBSDが11.1-RELEASE-p1になりました
(2.3.4_1だと10.3-RELEASE-p19)
p1なので2017年初めにあったOpenSSLに関する脆弱性は対応済です
(CVE-2017-3730 CVE-2017-3731 CVE-2017-3732)

インストーラ変更によりUEFI対応やZFS対応になりましたが
既存システムには影響ありません
アップデートしてもUFSのまま使えます
ZFSにしたい場合はpfSenseを再インストールすることになります

OpenVPNが2.4系になっているのでOpenVPNを使用している環境の場合
アップデート後に接続確認した方がいいです
リリースノートにも記載されてるerror=CRL has expiredが
一番遭遇するケースでしょうからアップデート前に
CRLの期限を確認した方がいいかもしれません

ESXi 6.5.0 U1(Bulld 6765664)上でpfSenseを動かしている場合は
ごく稀にブート時にクラッシュするとの報告が記載されてますので
該当環境の場合はリリースノートを確認の上、ご注意ください

パッケージ更新数が多いので更新には普段より時間がかかります
当然パッケージダウンロード時間で大きく左右されますが
私の環境では普段のマイナーアップデートで作業全体が5分程度
今回は15分ほどかかりました

時間的な余裕をもって更新しましょう

アップデートの手順

事前に設定のバックアップをした上で以下の操作でアップデートを実行
手順はいつもと同じでWEBGUIから実行できます

まずダッシュボードのVersionのところにある雲マークか
System→Updateを選択

2.3.4_1から2.4.0へアップデートと表示出てるのを確認して「Confirm」を押す

無事に完了すると自動で再起動開始されます

ここで普段と違うのは普段の再起動は2分もあれば終わるのですが
今回は起動に5分ほどと結構時間がかかります
時間かかるのはこの時だけでこれ以降の再起動は通常通りすぐ復帰しますが
なかなか復帰しなくても焦らず待ちましょう
(コンソールは動いてますのでコンソールを見れる環境の場合は動きを確認できます)

再起動が無事終わって2.4.0になっていると新画面で迎えてくれます

ちなみに2.3.4_1時の旧画面はこちら

WEBGUIがリニューアルしちゃったのか?と心配になる所ですが
ログイン画面が変わってるだけで中は今までと変わりませんのでご安心を

2.4.0の初回ログイン時にpfSenseの商標についてのポップアップが出ます
右下のAcceptを押せば2回目からは表示されません

最後に2.4.0の状態で設定をバックアップして完了

2.4.0にするとダッシュボードにNetgate Service And Supportという
ウィジェットが右上に追加されてました
要は以前でいうpfSense Goldの代わりです
使用しない人は右上の×を押して消せば以前と同じ状態になります

Update時の処理ログ

>>> Updating repositories metadata... 
pkg: Warning: Major OS version upgrade detected.  Running "pkg-static install -f pkg" recommended
Updating pfSense-core repository catalogue...
pfSense-core repository is up to date.
Updating pfSense repository catalogue...
pfSense repository is up to date.
All repositories are up to date.
>>> Locking package pkg... done.
>>> Unlocking package pfSense-kernel-pfSense... done.
>>> Setting vital flag on pkg... done.
>>> Setting vital flag on pfSense-kernel-pfSense... done.
>>> Setting vital flag on pfSense... done.
>>> Setting vital flag on pfSense-rc... done.
>>> Setting vital flag on pfSense-base... done.
>>> Unlocking package pkg... done.
>>> Downloading upgrade packages... 
pkg: Warning: Major OS version upgrade detected.  Running "pkg-static install -f pkg" recommended
Updating pfSense-core repository catalogue...
pfSense-core repository is up to date.
Updating pfSense repository catalogue...
pfSense repository is up to date.
All repositories are up to date.
Checking for upgrades (126 candidates): .......... done
Processing candidates (126 candidates): .......... done
The following 148 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
  python2: 2_3 [pfSense]
  readline: 7.0.3 [pfSense]
  oniguruma6: 6.4.0 [pfSense]
  pecl-rrd1: 1.1.3 [pfSense]
  pear-Crypt_CHAP: 1.5.0 [pfSense]
  pear: 1.10.5 [pfSense]
  openvpn: 2.4.4 [pfSense]
  liblz4: 1.8.0,1 [pfSense]
  pear-XML_RPC2: 1.1.3 [pfSense]
  pear-HTTP_Request2: 2.3.0,1 [pfSense]
  pear-Net_URL2: 2.2.1 [pfSense]
  pear-Cache_Lite: 1.7.16,1 [pfSense]
  pear-Net_IPv6: 1.3.0.b2_2 [pfSense]
  pear-Net_Growl: 2.7.0 [pfSense]
  pear-Auth_RADIUS: 1.1.0 [pfSense]
  mobile-broadband-provider-info: 20170310 [pfSense]
  pear-Mail: 1.4.1,1 [pfSense]
  pear-Net_SMTP: 1.8.0 [pfSense]
  pear-Net_Socket: 1.0.14 [pfSense]
  luajit: 2.0.5 [pfSense]
  libidn2: 2.0.4 [pfSense]
  libunistring: 0.9.7 [pfSense]

Installed packages to be UPGRADED:
  unbound: 1.6.1 -> 1.6.6 [pfSense]
  uclcmd: 0.1_1 -> 0.1_2 [pfSense]
  strongswan: 5.5.1_1 -> 5.6.0 [pfSense]
  ssh_tunnel_shell: 0.1 -> 0.1_1 [pfSense]
  sqlite3: 3.17.0 -> 3.20.1_1 [pfSense]
  rrdtool: 1.6.0_1 -> 1.7.0_1 [pfSense]
  qstats: 0.1_1 -> 0.2 [pfSense]
  python27: 2.7.13_3 -> 2.7.14 [pfSense]
  php56-pfSense-module: 0.13 -> 0.54 [pfSense]
  php56-mbstring: 5.6.31 -> 5.6.31_1 [pfSense]
  pfSense-repo: 2.3.4_7 -> 2.4.0 [pfSense]
  pfSense-rc: 2.3.4_1 -> 2.4.0 [pfSense-core]
  pfSense-kernel-pfSense: 2.3.4_1 -> 2.4.0 [pfSense-core]
  pfSense-default-config: 2.3.4_1 -> 2.4.0 [pfSense-core]
  pfSense-base: 2.3.4_1 -> 2.4.0 [pfSense-core]
  pfSense-Status_Monitoring: 1.6.1_3 -> 1.7.2 [pfSense]
  pfSense: 2.3.4_1 -> 2.4.0 [pfSense]
  perl5: 5.24.1 -> 5.24.3 [pfSense]
  pcre: 8.40 -> 8.40_1 [pfSense]
  openldap-client: 2.4.44 -> 2.4.45 [pfSense]
  nginx: 1.12.1,2 -> 1.12.1_1,2 [pfSense]
  mpd5: 5.8 -> 5.8_2 [pfSense]
  libzmq4: 4.1.5 -> 4.2.2 [pfSense]
  libnghttp2: 1.21.0 -> 1.26.0 [pfSense]
  libiconv: 1.14_10 -> 1.14_11 [pfSense]
  libffi: 3.2.1 -> 3.2.1_1 [pfSense]
  libedit: 3.1.20150325_2,1 -> 3.1.20170329_2,1 [pfSense]
  ldns: 1.7.0 -> 1.7.0_1 [pfSense]
  isc-dhcp43-server: 4.3.5 -> 4.3.6_1 [pfSense]
  isc-dhcp43-relay: 4.3.5 -> 4.3.6 [pfSense]
  isc-dhcp43-client: 4.3.5 -> 4.3.6 [pfSense]
  ipmitool: 1.8.18 -> 1.8.18_1 [pfSense]
  igmpproxy: 0.1_3,1 -> 0.1_5,1 [pfSense]
  glib: 2.46.2_5 -> 2.50.2_6,1 [pfSense]
  filterlog: 0.1_4 -> 0.1_5 [pfSense]
  filterdns: 1.0_9 -> 1.0_16 [pfSense]
  expat: 2.2.0_1 -> 2.2.1 [pfSense]
  dpinger: 2.0 -> 2.0_1 [pfSense]
  dnsmasq: 2.76,1 -> 2.78,1 [pfSense]
  dmidecode: 3.0 -> 3.1_1 [pfSense]
  curl: 7.54.1 -> 7.56.0 [pfSense]
  clog: 1.0.1 -> 1.0.1_1 [pfSense]
  check_reload_status: 0.0.7 -> 0.0.8 [pfSense]
  ca_root_nss: 3.30.2 -> 3.32.1 [pfSense]
  bind-tools: 9.11.1P1 -> 9.11.2 [pfSense]

Installed packages to be REINSTALLED:
  xinetd-2.3.15_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  wrapalixresetbutton-0.0.7 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  wol-0.7.1_3 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  vstr-1.0.15_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  voucher-0.1_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  sshlockout_pf-0.0.2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  smartmontools-6.5_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  scponly-4.8.20110526_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  relayd-5.5.20140810_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  rate-0.9_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  radvd-1.9.1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  pkg-1.10.1_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-zlib-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-xmlwriter-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-xmlreader-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-xml-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-tokenizer-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-sysvshm-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-sysvsem-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-sysvmsg-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-sqlite3-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-sockets-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-simplexml-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-shmop-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-session-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-readline-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-posix-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-pdo_sqlite-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-pdo-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-pcntl-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-openssl-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-opcache-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-mcrypt-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-ldap-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-json-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-hash-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-gettext-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-filter-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-dom-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-curl-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-ctype-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-bz2-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-bcmath-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php-xdebug-2.5.0 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php-suhosin-0.9.38_3 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  pftop-0.7_8 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  pecl-zmq-1.1.3_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  pecl-radius-1.4.0.b1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  ntp-4.2.8p10_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  norm-1.5r6 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  nettle-3.3 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  miniupnpd-1.9.20160113,1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  minicron-0.0.2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  lzo2-2.10_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  links-2.13,1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  libxml2-2.9.4 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  libucl-0.8.0 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  libssh2-1.8.0,3 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  libsodium-1.0.12 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  libmcrypt-2.5.8_3 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  libltdl-2.4.6 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  libevent-2.1.8 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  libdaemon-0.14_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  json-c-0.12.1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  indexinfo-0.2.6 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  idnkit-1.0_6 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  gmp-6.1.2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  gettext-runtime-0.19.8.1_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  expiretable-0.6_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  dhcpleases6-0.1_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  dhcpleases-0.3_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  dhcp6-20080615.2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  cpustats-0.1_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  cpdup-1.18 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  choparp-20150613 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  bwi-firmware-kmod-3.130.20 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  bsnmp-ucd-0.4.2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  bsnmp-regex-0.6_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  beep-1.0_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  ataidle-2.7.2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')

Number of packages to be installed: 22
Number of packages to be upgraded: 45
Number of packages to be reinstalled: 81

The process will require 35 MiB more space.
108 MiB to be downloaded.
[1/148] Fetching xinetd-2.3.15_2.txz: .......... done
[2/148] Fetching wrapalixresetbutton-0.0.7.txz: . done
[3/148] Fetching wol-0.7.1_3.txz: .... done
[4/148] Fetching vstr-1.0.15_1.txz: .......... done
[5/148] Fetching voucher-0.1_2.txz: . done
[6/148] Fetching unbound-1.6.6.txz: .......... done
[7/148] Fetching uclcmd-0.1_2.txz: .. done
[8/148] Fetching strongswan-5.6.0.txz: .......... done
[9/148] Fetching sshlockout_pf-0.0.2.txz: . done
[10/148] Fetching ssh_tunnel_shell-0.1_1.txz: .......... done
[11/148] Fetching sqlite3-3.20.1_1.txz: .......... done
[12/148] Fetching smartmontools-6.5_2.txz: .......... done
[13/148] Fetching scponly-4.8.20110526_2.txz: ... done
[14/148] Fetching rrdtool-1.7.0_1.txz: .......... done
[15/148] Fetching relayd-5.5.20140810_2.txz: .......... done
[16/148] Fetching rate-0.9_1.txz: ....... done
[17/148] Fetching radvd-1.9.1.txz: ...... done
[18/148] Fetching qstats-0.2.txz: . done
[19/148] Fetching python27-2.7.14.txz: .......... done
[20/148] Fetching pkg-1.10.1_1.txz: .......... done
[21/148] Fetching php56-zlib-5.6.31.txz: .. done
[22/148] Fetching php56-xmlwriter-5.6.31.txz: .. done
[23/148] Fetching php56-xmlreader-5.6.31.txz: .. done
[24/148] Fetching php56-xml-5.6.31.txz: ... done
[25/148] Fetching php56-tokenizer-5.6.31.txz: . done
[26/148] Fetching php56-sysvshm-5.6.31.txz: . done
[27/148] Fetching php56-sysvsem-5.6.31.txz: . done
[28/148] Fetching php56-sysvmsg-5.6.31.txz: .. done
[29/148] Fetching php56-sqlite3-5.6.31.txz: ... done
[30/148] Fetching php56-sockets-5.6.31.txz: ..... done
[31/148] Fetching php56-simplexml-5.6.31.txz: ... done
[32/148] Fetching php56-shmop-5.6.31.txz: . done
[33/148] Fetching php56-session-5.6.31.txz: .... done
[34/148] Fetching php56-readline-5.6.31.txz: .. done
[35/148] Fetching php56-posix-5.6.31.txz: .. done
[36/148] Fetching php56-pfSense-module-0.54.txz: ..... done
[37/148] Fetching php56-pdo_sqlite-5.6.31.txz: .. done
[38/148] Fetching php56-pdo-5.6.31.txz: ...... done
[39/148] Fetching php56-pcntl-5.6.31.txz: .. done
[40/148] Fetching php56-openssl-5.6.31.txz: ...... done
[41/148] Fetching php56-opcache-5.6.31.txz: ........ done
[42/148] Fetching php56-mcrypt-5.6.31.txz: .. done
[43/148] Fetching php56-mbstring-5.6.31_1.txz: .......... done
[44/148] Fetching php56-ldap-5.6.31.txz: ... done
[45/148] Fetching php56-json-5.6.31.txz: ... done
[46/148] Fetching php56-hash-5.6.31.txz: .......... done
[47/148] Fetching php56-gettext-5.6.31.txz: . done
[48/148] Fetching php56-filter-5.6.31.txz: ... done
[49/148] Fetching php56-dom-5.6.31.txz: ....... done
[50/148] Fetching php56-curl-5.6.31.txz: .... done
[51/148] Fetching php56-ctype-5.6.31.txz: . done
[52/148] Fetching php56-bz2-5.6.31.txz: .. done
[53/148] Fetching php56-bcmath-5.6.31.txz: ... done
[54/148] Fetching php56-5.6.31.txz: .......... done
[55/148] Fetching php-xdebug-2.5.0.txz: .......... done
[56/148] Fetching php-suhosin-0.9.38_3.txz: ........ done
[57/148] Fetching pftop-0.7_8.txz: ........ done
[58/148] Fetching pfSense-repo-2.4.0.txz: . done
[59/148] Fetching pfSense-rc-2.4.0.txz: .. done
[60/148] Fetching pfSense-kernel-pfSense-2.4.0.txz: .......... done
[61/148] Fetching pfSense-default-config-2.4.0.txz: . done
[62/148] Fetching pfSense-base-2.4.0.txz: .......... done
[63/148] Fetching pfSense-Status_Monitoring-1.7.2.txz: ... done
[64/148] Fetching pfSense-2.4.0.txz: . done
[65/148] Fetching perl5-5.24.3.txz: .......... done
[66/148] Fetching pecl-zmq-1.1.3_2.txz: ... done
[67/148] Fetching pecl-radius-1.4.0.b1.txz: ... done
[68/148] Fetching pcre-8.40_1.txz: .......... done
[69/148] Fetching openldap-client-2.4.45.txz: .......... done
[70/148] Fetching ntp-4.2.8p10_2.txz: .......... done
[71/148] Fetching norm-1.5r6.txz: .......... done
[72/148] Fetching nginx-1.12.1_1,2.txz: .......... done
[73/148] Fetching nettle-3.3.txz: .......... done
[74/148] Fetching mpd5-5.8_2.txz: .......... done
[75/148] Fetching miniupnpd-1.9.20160113,1.txz: ....... done
[76/148] Fetching minicron-0.0.2.txz: . done
[77/148] Fetching lzo2-2.10_1.txz: .......... done
[78/148] Fetching links-2.13,1.txz: .......... done
[79/148] Fetching libzmq4-4.2.2.txz: .......... done
[80/148] Fetching libxml2-2.9.4.txz: .......... done
[81/148] Fetching libucl-0.8.0.txz: .......... done
[82/148] Fetching libssh2-1.8.0,3.txz: .......... done
[83/148] Fetching libsodium-1.0.12.txz: .......... done
[84/148] Fetching libnghttp2-1.26.0.txz: .......... done
[85/148] Fetching libmcrypt-2.5.8_3.txz: .......... done
[86/148] Fetching libltdl-2.4.6.txz: ..... done
[87/148] Fetching libiconv-1.14_11.txz: .......... done
[88/148] Fetching libffi-3.2.1_1.txz: ..... done
[89/148] Fetching libevent-2.1.8.txz: .......... done
[90/148] Fetching libedit-3.1.20170329_2,1.txz: .......... done
[91/148] Fetching libdaemon-0.14_1.txz: ... done
[92/148] Fetching ldns-1.7.0_1.txz: .......... done
[93/148] Fetching json-c-0.12.1.txz: ..... done
[94/148] Fetching isc-dhcp43-server-4.3.6_1.txz: .......... done
[95/148] Fetching isc-dhcp43-relay-4.3.6.txz: .......... done
[96/148] Fetching isc-dhcp43-client-4.3.6.txz: .......... done
[97/148] Fetching ipmitool-1.8.18_1.txz: .......... done
[98/148] Fetching indexinfo-0.2.6.txz: . done
[99/148] Fetching igmpproxy-0.1_5,1.txz: ... done
[100/148] Fetching idnkit-1.0_6.txz: .......... done
[101/148] Fetching gmp-6.1.2.txz: .......... done
[102/148] Fetching glib-2.50.2_6,1.txz: .......... done
[103/148] Fetching gettext-runtime-0.19.8.1_1.txz: .......... done
[104/148] Fetching filterlog-0.1_5.txz: .. done
[105/148] Fetching filterdns-1.0_16.txz: ... done
[106/148] Fetching expiretable-0.6_1.txz: . done
[107/148] Fetching expat-2.2.1.txz: .......... done
[108/148] Fetching dpinger-2.0_1.txz: .. done
[109/148] Fetching dnsmasq-2.78,1.txz: .......... done
[110/148] Fetching dmidecode-3.1_1.txz: ....... done
[111/148] Fetching dhcpleases6-0.1_2.txz: .. done
[112/148] Fetching dhcpleases-0.3_1.txz: .. done
[113/148] Fetching dhcp6-20080615.2.txz: .......... done
[114/148] Fetching curl-7.56.0.txz: .......... done
[115/148] Fetching cpustats-0.1_1.txz: . done
[116/148] Fetching cpdup-1.18.txz: .... done
[117/148] Fetching clog-1.0.1_1.txz: . done
[118/148] Fetching choparp-20150613.txz: . done
[119/148] Fetching check_reload_status-0.0.8.txz: .... done
[120/148] Fetching ca_root_nss-3.32.1.txz: .......... done
[121/148] Fetching bwi-firmware-kmod-3.130.20.txz: ... done
[122/148] Fetching bsnmp-ucd-0.4.2.txz: ... done
[123/148] Fetching bsnmp-regex-0.6_1.txz: ... done
[124/148] Fetching bind-tools-9.11.2.txz: .......... done
[125/148] Fetching beep-1.0_1.txz: . done
[126/148] Fetching ataidle-2.7.2.txz: .. done
[127/148] Fetching python2-2_3.txz: . done
[128/148] Fetching readline-7.0.3.txz: .......... done
[129/148] Fetching oniguruma6-6.4.0.txz: .......... done
[130/148] Fetching pecl-rrd1-1.1.3.txz: .. done
[131/148] Fetching pear-Crypt_CHAP-1.5.0.txz: . done
[132/148] Fetching pear-1.10.5.txz: .......... done
[133/148] Fetching openvpn-2.4.4.txz: .......... done
[134/148] Fetching liblz4-1.8.0,1.txz: .......... done
[135/148] Fetching pear-XML_RPC2-1.1.3.txz: ........ done
[136/148] Fetching pear-HTTP_Request2-2.3.0,1.txz: .......... done
[137/148] Fetching pear-Net_URL2-2.2.1.txz: ... done
[138/148] Fetching pear-Cache_Lite-1.7.16,1.txz: .... done
[139/148] Fetching pear-Net_IPv6-1.3.0.b2_2.txz: .. done
[140/148] Fetching pear-Net_Growl-2.7.0.txz: .......... done
[141/148] Fetching pear-Auth_RADIUS-1.1.0.txz: .. done
[142/148] Fetching mobile-broadband-provider-info-20170310.txz: ..... done
[143/148] Fetching pear-Mail-1.4.1,1.txz: ... done
[144/148] Fetching pear-Net_SMTP-1.8.0.txz: .. done
[145/148] Fetching pear-Net_Socket-1.0.14.txz: . done
[146/148] Fetching luajit-2.0.5.txz: .......... done
[147/148] Fetching libidn2-2.0.4.txz: .......... done
[148/148] Fetching libunistring-0.9.7.txz: .......... done
Checking integrity... done (3 conflicting)
  - oniguruma6-6.4.0 [pfSense] conflicts with oniguruma5-5.9.6_1 [installed] on /usr/local/bin/onig-config
  - pecl-rrd1-1.1.3 [pfSense] conflicts with pecl-rrd-1.1.3_4 [installed] on /usr/local/lib/php/20131226/rrd.so
  - openvpn-2.4.4 [pfSense] conflicts with openvpn23-2.3.17 [installed] on /usr/local/include/openvpn-plugin.h
Checking integrity... done (0 conflicting)
Conflicts with the existing packages have been found.
One more solver iteration is needed to resolve them.
The following 151 package(s) will be affected (of 0 checked):

Installed packages to be REMOVED:
  oniguruma5-5.9.6_1
  pecl-rrd-1.1.3_4
  openvpn23-2.3.17

New packages to be INSTALLED:
  readline: 7.0.3 [pfSense]
  python2: 2_3 [pfSense]
  pear: 1.10.5 [pfSense]
  pear-Net_URL2: 2.2.1 [pfSense]
  pear-Net_Socket: 1.0.14 [pfSense]
  libunistring: 0.9.7 [pfSense]
  oniguruma6: 6.4.0 [pfSense]
  pecl-rrd1: 1.1.3 [pfSense]
  liblz4: 1.8.0,1 [pfSense]
  pear-HTTP_Request2: 2.3.0,1 [pfSense]
  pear-Cache_Lite: 1.7.16,1 [pfSense]
  pear-Net_SMTP: 1.8.0 [pfSense]
  luajit: 2.0.5 [pfSense]
  libidn2: 2.0.4 [pfSense]
  pear-Crypt_CHAP: 1.5.0 [pfSense]
  openvpn: 2.4.4 [pfSense]
  pear-XML_RPC2: 1.1.3 [pfSense]
  pear-Net_IPv6: 1.3.0.b2_2 [pfSense]
  pear-Net_Growl: 2.7.0 [pfSense]
  pear-Auth_RADIUS: 1.1.0 [pfSense]
  mobile-broadband-provider-info: 20170310 [pfSense]
  pear-Mail: 1.4.1,1 [pfSense]

Installed packages to be UPGRADED:
  pcre: 8.40 -> 8.40_1 [pfSense]
  libffi: 3.2.1 -> 3.2.1_1 [pfSense]
  python27: 2.7.13_3 -> 2.7.14 [pfSense]
  perl5: 5.24.1 -> 5.24.3 [pfSense]
  libiconv: 1.14_10 -> 1.14_11 [pfSense]
  libnghttp2: 1.21.0 -> 1.26.0 [pfSense]
  ldns: 1.7.0 -> 1.7.0_1 [pfSense]
  glib: 2.46.2_5 -> 2.50.2_6,1 [pfSense]
  expat: 2.2.0_1 -> 2.2.1 [pfSense]
  ca_root_nss: 3.30.2 -> 3.32.1 [pfSense]
  unbound: 1.6.1 -> 1.6.6 [pfSense]
  rrdtool: 1.6.0_1 -> 1.7.0_1 [pfSense]
  curl: 7.54.1 -> 7.56.0 [pfSense]
  strongswan: 5.5.1_1 -> 5.6.0 [pfSense]
  sqlite3: 3.17.0 -> 3.20.1_1 [pfSense]
  openldap-client: 2.4.44 -> 2.4.45 [pfSense]
  libzmq4: 4.1.5 -> 4.2.2 [pfSense]
  libedit: 3.1.20150325_2,1 -> 3.1.20170329_2,1 [pfSense]
  uclcmd: 0.1_1 -> 0.1_2 [pfSense]
  ssh_tunnel_shell: 0.1 -> 0.1_1 [pfSense]
  qstats: 0.1_1 -> 0.2 [pfSense]
  php56-pfSense-module: 0.13 -> 0.54 [pfSense]
  php56-mbstring: 5.6.31 -> 5.6.31_1 [pfSense]
  pfSense-repo: 2.3.4_7 -> 2.4.0 [pfSense]
  pfSense-rc: 2.3.4_1 -> 2.4.0 [pfSense-core]
  pfSense-Status_Monitoring: 1.6.1_3 -> 1.7.2 [pfSense]
  nginx: 1.12.1,2 -> 1.12.1_1,2 [pfSense]
  mpd5: 5.8 -> 5.8_2 [pfSense]
  isc-dhcp43-server: 4.3.5 -> 4.3.6_1 [pfSense]
  isc-dhcp43-relay: 4.3.5 -> 4.3.6 [pfSense]
  isc-dhcp43-client: 4.3.5 -> 4.3.6 [pfSense]
  ipmitool: 1.8.18 -> 1.8.18_1 [pfSense]
  igmpproxy: 0.1_3,1 -> 0.1_5,1 [pfSense]
  filterlog: 0.1_4 -> 0.1_5 [pfSense]
  filterdns: 1.0_9 -> 1.0_16 [pfSense]
  dpinger: 2.0 -> 2.0_1 [pfSense]
  dnsmasq: 2.76,1 -> 2.78,1 [pfSense]
  dmidecode: 3.0 -> 3.1_1 [pfSense]
  clog: 1.0.1 -> 1.0.1_1 [pfSense]
  check_reload_status: 0.0.7 -> 0.0.8 [pfSense]
  bind-tools: 9.11.1P1 -> 9.11.2 [pfSense]
  pfSense-kernel-pfSense: 2.3.4_1 -> 2.4.0 [pfSense-core]
  pfSense-default-config: 2.3.4_1 -> 2.4.0 [pfSense-core]
  pfSense-base: 2.3.4_1 -> 2.4.0 [pfSense-core]
  pfSense: 2.3.4_1 -> 2.4.0 [pfSense]

Installed packages to be REINSTALLED:
  libxml2-2.9.4 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  indexinfo-0.2.6 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  gettext-runtime-0.19.8.1_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-zlib-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-xml-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  libevent-2.1.8 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  vstr-1.0.15_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  norm-1.5r6 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  libsodium-1.0.12 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  libmcrypt-2.5.8_3 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  libltdl-2.4.6 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  gmp-6.1.2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-session-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-pdo-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-mcrypt-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-hash-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-dom-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-curl-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  pecl-radius-1.4.0.b1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  nettle-3.3 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  lzo2-2.10_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  libucl-0.8.0 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  libdaemon-0.14_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  json-c-0.12.1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  idnkit-1.0_6 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  xinetd-2.3.15_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  wrapalixresetbutton-0.0.7 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  wol-0.7.1_3 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  voucher-0.1_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  sshlockout_pf-0.0.2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  smartmontools-6.5_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  scponly-4.8.20110526_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  relayd-5.5.20140810_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  rate-0.9_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  radvd-1.9.1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-xmlwriter-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-xmlreader-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-tokenizer-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-sysvshm-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-sysvsem-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-sysvmsg-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-sqlite3-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-sockets-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-simplexml-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-shmop-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-readline-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-posix-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-pdo_sqlite-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-pcntl-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-openssl-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-opcache-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-ldap-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-json-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-gettext-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-filter-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-ctype-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-bz2-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php56-bcmath-5.6.31 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php-xdebug-2.5.0 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  php-suhosin-0.9.38_3 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  pftop-0.7_8 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  pecl-zmq-1.1.3_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  ntp-4.2.8p10_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  miniupnpd-1.9.20160113,1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  minicron-0.0.2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  links-2.13,1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  expiretable-0.6_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  dhcpleases6-0.1_2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  dhcpleases-0.3_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  dhcp6-20080615.2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  cpustats-0.1_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  cpdup-1.18 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  choparp-20150613 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  bwi-firmware-kmod-3.130.20 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  bsnmp-ucd-0.4.2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  bsnmp-regex-0.6_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  beep-1.0_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  ataidle-2.7.2 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  pkg-1.10.1_1 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')
  libssh2-1.8.0,3 [pfSense] (ABI changed: 'freebsd:10:x86:64' -> 'freebsd:11:x86:64')

Number of packages to be removed: 3
Number of packages to be installed: 22
Number of packages to be upgraded: 45
Number of packages to be reinstalled: 81

The process will require 33 MiB more space.
>>> Downloading pkg... 
pkg: Warning: Major OS version upgrade detected.  Running "pkg-static install -f pkg" recommended
Updating pfSense-core repository catalogue...
pfSense-core repository is up to date.
Updating pfSense repository catalogue...
pfSense repository is up to date.
All repositories are up to date.
Checking integrity... done (0 conflicting)
The following 1 package(s) will be affected (of 0 checked):

Installed packages to be REINSTALLED:
  pkg-1.10.1_1 [pfSense]

Number of packages to be reinstalled: 1

The process will require 1 MiB more space.
>>> Locking package pkg... done.
>>> Upgrading pfSense kernel... 
pkg: Warning: Major OS version upgrade detected.  Running "pkg-static install -f pkg" recommended

pkg-1.10.1_1 is locked and may not be modified
Checking integrity... done (0 conflicting)
The following 2 package(s) will be affected (of 0 checked):

Installed packages to be UPGRADED:
  pfSense-kernel-pfSense: 2.3.4_1 -> 2.4.0 [pfSense-core]
  pfSense-rc: 2.3.4_1 -> 2.4.0 [pfSense-core]

Number of packages to be upgraded: 2

The process will require 6 MiB more space.
[1/2] Upgrading pfSense-rc from 2.3.4_1 to 2.4.0...
[1/2] Extracting pfSense-rc-2.4.0: .... done
[2/2] Upgrading pfSense-kernel-pfSense from 2.3.4_1 to 2.4.0...
[2/2] Extracting pfSense-kernel-pfSense-2.4.0: .......... done
===> Keeping a copy of current kernel in /boot/kernel.old
Upgrade is complete.  Rebooting in 10 seconds.
Success

2.4.0での動作について

各設定も2.4.0にも無事に引き継がれていて
まだ半日ですが今のところ安定してます

安定性には問題ないですが2.3.4の頃より少しですがリソースを食ってるようです
以前からSNMP経由でリソース監視してるわけですがグラフを見ると一目瞭然
左が前日で右が当日
アプデの前日はアイドル時の変化を見るためVPNなど使ったりせずに
普通のブラウジング程度だけで使うことにしているので負荷かかってません

アップデート作業時は監視を止めてるのでメモリ使用率の切れ目で境がわかると思います
プロセス数が10ほど上がっておりメモリも多少上がってますが
それよりもCPU使用率とロードアベレージが明らかに上がってます

CPU使用率は2.3.4_1の時はほぼ0で推移しているわけですが
2.4.0は全体的に線が見える程度に上がってます
跳ね上がってるところは管理画面をいじってるときなので仕方ないですが
いじってない時も平均的に若干高くなった印象

管理画面のダッシュボード上でも
CPU使用率が3-5%上昇・温度が3度ほど上昇してるのが確認出来ましたが
SSHでプロセス確認しても管理画面開いているときにnginx・phpが重いぐらいで
他に管理画面操作以外の重い常駐プロセスは確認できませんでした

プロセスというよりFreeBSD11.1の影響でCPUの使い方が変わったのかもしれませんが
その辺の情報が入ってきてないので現状わかりません

アプデ直後でなにか裏でしている可能性もあるので
その場合でも次のマイナーアップデート時までには
落ち着いてるでしょうからまた改めてチェックしたいと思います

最後に

管理画面のFaviconも新しいロゴに変更されて
今時の感じになりましたね

2.4.0自体は少し前に完了していたのですが
dnsmasqの脆弱性が発覚してその対応で遅くなってました
(CVE-2017-14491など)
当初2.4.0はFreeBSD11.0で2.4.1でFreeBSD11.1になる予定だったのに
2.4.0でFreeBSD11.1にしてきたのもこの影響です

dnsmasqはpfSense内でいうとDNS Forwarderです
pfSense2.2から標準でDNS Resolver(Unbound)を使用しており
移行を推奨されている状態なので影響も受けるユーザも一部ですが
この辺をちゃんと切り捨てず修正待ちをしてのリリース対応してくるあたり
ゴタゴタすぎるどっかのNASチームとは違うなと思わせてくれます

2.4.0へのメジャーアップデートを人柱報告待ちしてる人向けにも
dnsmasq修正版の2.3.5リリースが予定されていますし
pkgコマンドで今すぐアップデートする手段も用意されていますので
今回の問題だけですぐに2.4.0へアップデートをする必要はありません